NXT 2.0 sound problem fixed by re-install, make new blocks

Discussion specific to NXT-G, NXC, NBC, RobotC, Lejos, and more.
Post Reply
Posts: 1
Joined: 04 Oct 2017, 16:57

NXT 2.0 sound problem fixed by re-install, make new blocks

Post by tgronke »

Students using the Mindstorms NXT 2.0 software on a Windows 7 laptop (Home Premium, 32-bit) had a problem with sounds in their program not playing on the brick. The solution was uninstall/re-install of the Lego Mindstorms NXT 2.0 software on the laptop, but we also need to create new programs after re-installing the software.

I help teach an after-school robotics class in our elementary school with used NXT robotics educational sets and old Windows laptops. We started the year with the same equipment that worked last spring without any cleanup. On this laptop (like others) the NXT 2.0 software was installed from the administrator account, and students access the software through a Guest account on the computer. The only work with the computers over the summer was installing operating system and application patches as prompted.

On one laptop, the students performed the simple lab of creating a one-block sound program and downloading to the brick. No sound came out. When the program was modified to play the same sound in an infinite loop, a soft buzzing came from the brick when the program was downloaded and run. We tried another working brick on the same laptop and got the same result with this program. We used the suspect brick on another laptop, using an almost-identical program created by other students on that laptop - that program played sounds. Later, I tried the same action under the Administrator account on the suspect laptop with the same results. We concluded there was likely a problem with the software or sound files on the suspect laptop.

Re-installing the software appeared to make no difference - the same program still made no sound. I tried switching sounds in the program, but it still played nothing. I reinstalled the firmware on the brick, but still no change. Checking the brick memory, I noted everytime I switched sounds in the program, a new sound file downloaded to the brick.

I fully uninstalled the software on the laptop, removed additional driver programs that did not get removed by the Uninstall tool, rebooted, and re-installed again. On a guess, I created a new program identical to the non-working program. The sound played. I opened the earlier problem program, changed the sound and again download - still no sound in the suspect program.

I concluded that whatever corrupted the earlier program corrupted the sound block as it was placed in the program space, and changing parameters of the sound does not re-create the block. I'll test that theory by moving this problem program to a known working laptop to see if the sound problem follows the program, and also adding another sound block to the suspect program to find if it's specific to the block as it's placed in the program.
Post Reply

Who is online

Users browsing this forum: No registered users and 1 guest