Page 1 of 1

"Clicking" NXT 2.0 and Linux firmware upload

Posted: 05 May 2020, 22:05
by cmskipsey
Just got my son a used NXT 2.0 kit. I put batteries in it, and it first played a tune (which might have been the regular startup tune) but then quickly went to a clicking sound.

I've read that this means the firmware is corrupt or didn't finish uploading correctly. In any case, I need to upload a new firmware

I run Arch Linux and MacOS Catalina (10.15) so NXT-G isn't an option (without running a Windows 7 VM)

Question: should I at least be able to "see" the device on the USB bus with

Code: Select all

while it is in this "clicking" mode?

I've tried the following on Linux:

- leJOS NXJ - runs an error about

Code: Select all

driver (can't find out how to install this driver in Linux, not sure if it means the Fantom driver which appears to be for Mac and Win only)

- libnxt - cannot compile because it wants an ARM cross-compiler which I haven't found yet

- bricxcc

Code: Select all


Code: Select all

- both complain about

Code: Select all

missing, can't install a compatible version

- Enchanting - only a .deb package available and don't know where to find source to compile an Arch version

I figured *someone* must be running NXT stuff on a modern Linux system somewhere! I'm not fussed what we use to program it - Python, C/C++ or graphical programming using Snap!, EV3 software (which *is* NXT compatible from what I've read)

Please help! My son was so pumped to get this kit but we're both super disappointed it's not up and running yet...